标签归档:firfox

Gentoo 下安装 Firefox 3 及(‘ebuild’, ‘/’, ‘www-client/mozilla-firefox-2.0.0.17’, ‘merge’) pulled in by (‘installed’, ‘/’, ‘gnome-extra/yelp-2.22.1-r2’, ‘nomerge’) 问题解决。

在 /etc/portage/package.keywords 添加下面的内容。

www-client/mozilla-firefox ~x86
dev-libs/nspr ~x86
dev-libs/nss ~x86
net-libs/xulrunner ~x86

在 /etc/make.conf 里的 USE 变量添加 xulrunner ,然会执行 sudo emerge firefox 就可以了。

如果忘了添加 xulrunner 会出现 yelp 依赖 firefox2 的现象出现下面的错误(添加上xulrunner就可以解决):

[email protected] ~ $ sudo emerge -p –update –deep –newuse world

These are the packages that would be merged, in order:

Calculating world dependencies –
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

www-client/mozilla-firefox:0

(‘ebuild’, ‘/’, ‘www-client/mozilla-firefox-2.0.0.17’, ‘merge’) pulled in by
(‘installed’, ‘/’, ‘gnome-extra/yelp-2.22.1-r2’, ‘nomerge’)

(‘installed’, ‘/’, ‘www-client/mozilla-firefox-3.0.3’, ‘nomerge’) (no parents)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

… done!
[ebuild UD] www-client/mozilla-firefox-2.0.0.17 [3.0.3] USE=”-debug% -filepicker% -moznopango% -xforms% -xinerama% -xprint%” LINGUAS=”-bg%”